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Summary 

Hydro-Québec is Quebec's main electricity producer. In order to meet the ever-growing 
demand for energy, the company must plan for the building of future hydroelectric plants 
in Quebec. With regard to this, the province's water system represents fundamental data 
for planning and managing facilities. 
 
Planning hydroelectric projects requires the creation of kilometre points (KP) and river 
profiles. This makes it possible to locate and identify any type of structure planned along 
a watercourse and makes it easier to identify drops. This document describes how Hydro-
Québec is creating the kilometre points and river profile from National Hydro Network 
(NHN) data. 
 

Work environment 

For this case, the software and data that were used are commonly used by the community. 
In terms of software, Global Mapper V10.00 and FME version FME2007 were used. In 
terms of the basic information, data from the National Hydro Network (NHN) from 
GeoBase as well as altimetric data from the Shuttle Radar Topography Mission (SRTM) 
were used. 
 

The challenge 

A few years ago, KPs were established based on hard-copy topographic maps (provincial 
topographic maps at 1:20,000 and federal topographic maps at 1:50,000 or 1:250,000 
depending on availability). These kilometre points were measured and identified on the 
map. When necessary, these points were then digitized. The river profile was generated 
based on the data (water levels) measured on the ground. Recently, kilometre points were 
established using digital topographic maps from the Base de données topographiques du 
Québec (BDTQ) at 1:20,000 and the National Digital Topographic Data Base (NTDB) at 
1:50,000. When possible, the river's centre line was digitized by following the 
watercourse's main flow (thalweg). 
 
As this work is long and tedious, l'Unité Géomatique [the Geomatics Work Unit] at 
Hydro-Québec Équipement set about improving this process to decrease response time 
while offering the best data currently available. Thus, since the advent of NHN data, 
identifying the centre line based on the NHN's Network Linear Flow feature has made it 
possible to obtain this information more quickly. Then, the main flow must be validated 
and the starting kilometre point (KP 0) must be set. With this new method, it is now 
possible to quickly meet the diverse needs of Hydro-Québec Équipement sub-units, 
especially the Développement de nouveaux aménagements de production Work Unit 
[Development of new production facilities Work Unit] and the Conception - 
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Aménagements de production hydraulique et géotechnique Work Unit [Design - 
Hydraulic and geotechnical production facilities Work Unit], which use these data to 
analyze the potential for future hydroelectric projects across the province. 
 
The text below describes, among other things, the steps that need to be followed to 
quickly succeed in creating a river profile and kilometre points. 
 

The solution 

1. Creating a river profile 

1.1. Opening a file 

From the Global Mapper application, follow "File" > "Open" to open the GML file 
containing the NHN dataset of the river being studied. 
Make sure to select the correct type of file (GML) from the drop-down menu found at 
the bottom of the dialogue box (Figure1.1). 
 

 
 

Figure 1.1. Opening a file 
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1.2. Selecting a river 

Select "Search by Attributes, Name and Description" under the main "Search" 
menu. In order to only select the Network Linear Flow features for the river in 
question, activate only the "Lines" geometry found in the first section of the "Search 
Vector Data" window, or "Types to Search" (Figure 1.2). In the second section of 
the window, select the field "GML2 :NOM1" (GML2 :NAME1) and enter the name 
of the desired river, which is "Romaine River" in this case. Next click the "NEW 
SEARCH" button. Once the elements have been found, click "Select All." The 
Network Linear Flow elements of the Romaine River are now selected. Now, all you 
have to do is isolate the objects on a new layer by clicking the "Edit Selected" 
button. 
 

 
 

Figure 1.2 Selecting a river 

 
Note: In the NHN data of the Completeness Level 1 (NHN-CL1) and 2 (NHN-CL2), 

it is very possible for the river toponym not to be present in attribute on all the 
Network Linear Flow feature elements that make up the river. If such is the 
case, the complete selection of all the Network Linear Flow elements that 
make up the river will require additional work. For more information 
regarding the NHN Completeness Levels, please read the following section on 
the GeoBase portal: NHN Completeness Levels. 
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1.3. Creating a new layer 

After clicking the "Edit Selected" button in the "Search Vector Data" window, a 
new window appears – the "Modify Selected Line Features" window. In the first 
section of the window, check "Modify Name" and in the text box of the "Feature 
Name" section type the river's name, which is "Riv_romaine" in this case. In the 
"Feature layer" section, select the "Create New Layer for Feature" option (Figure 
1.3a). Click "OK." A new window (Figure 1.3b) will appear asking the user to enter 
the name of the new layer, which is "Riv_Romaine" in this case. 
 

 
 

Figure 1.3a Creating a new layer 

 

 Figure 1.3a Saving a new layer 
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1.4. Controlling the layers 

Still in the Global Mapper application, in the "Tools" menu, select the "Control 
Center" item. In the "Overlay Control Center" window that appears (Figure 1.4), 
uncheck all the layers and save only the recently created layer, which is 
"Riv_romaine" in this case. Click the "Close" button. 
 

 
 

Figure 1.4 Controlling the layers 

 

1.5. Assembling the linear elements 

In the "View" menu of the Global Mapper application, select "Full View." Next, click 
the "Digitizer Tool" button (pen tracing icon) and select objects on the screen by 
dragging and dropping (click and drag) the mouse to put the desired elements in a 
bounding box (Figure 1.5a). Once the objects are selected, right-click on the mouse 
and select "Combine Selected Line Features" on the pop-up menu (Figure1.5b). 
 

 Page 7/17



 
 

Figure 1.5a Assembling the linear elements 
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Figure 1.5a Assembling the linear elements 

 

1.6. Opening a digital elevation model 

Refer to section 1.1 to open a digital elevation model in the Global Mapper 
application. Do not forget to select the correct file type, which is "All Supported 
Raster Types," then open the matrix data (Raster) that corresponds to the zone of 
interest. The SRTM Raster data are used here. 

1.7. Creating a river profile 

Once the two data layers (vector and Raster data) are open in the Global Mapper 
application, click the "Digitizer Tool" button (pen tracing icon) and graphically select 
the vector (i.e. the river). Next, right-click on the mouse and select the "Generate 
Path Profile Along Line" option on the pop-up menu (Figure 1.7). 
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Figure 1.7 Creating a river profile 

 

1.8. Exporting data 

Now it is possible to export the river profile values in ASCII format so that they can 
be subsequently imported into another program (e.g. spreadsheet program). From the 
"Path Profile/Line of Sight" window of the Global Mapper application, select "Save 
Distance/Elevation File," which is found in the "File" menu (Figure 1.8). 
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Figure 1.8 Exporting data 
 
 

In order to obtain a coherent river profile using SRTM data, only the data matching 
the low points of the profile are saved. Because these are average altimetric values, a 
river profile that goes through steep locations (e.g. a canyon) will have higher 
altimetric values than actually found in reality. This is why only the low points of the 
exported ASCII file are saved. 

2. Identifying Kilometre Points (KP) 

2.1. Exporting the Centre Line (CL) 

Still in the Global Mapper application, save only the visible "Riv_romaine" layer, as 
previously explained in section 1.4. In the "File" menu, select "Export Vector Data" 
and select the desired format (Figure 2.1), which is "Export MapInfo TAB/MAP…" 
in this case. Next, accept the default parameters and save the file, in this case under 
the name "Riv_romaine.tab." 
 

 
 

Figure 2.1 Export format 
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2.2. Opening data 

Start the FME Workbench application, activate the "Use the workspace wizard" 
button and click "OK" (Figure 2.2a). 
 

 
 

Figure 2.2a 

 
Select the desired format (Figure 2.2b), which is the format chosen in section 2.1 (i.e. 
MapInfo TAB), then click the "Next" button. 
 

 
 

Figure.2.2b 

 
Next, choose the file that was saved in section 2.1, "Riv_romaine.tab," then click the 
"Next" button. 
 
Finally, select the destination format (Figure 2.2c), MapInfo TAB in this case, and 
click the "Next" button and then "Finish" in order to confirm the result (Figure 2.2d). 
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Figure.2.2c 

 

 
 

Figure.2.2d 

 

2.3. Integrating the tool 

In the "Transformers" section, in the second panel on the left of the FME 
Workbench application, select the "DistanceMarker" tool and drag and drop it into 
the Main panel, which presents the diagram of the data processing process (Figure 
2.3a). Next, link the data source and destination connectors to this tool 
(DistanceMarker transformer) (Figure 2.3b). Consult FME Help for more 
information on this topic. 
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Figure 2.3a 

 

 
 

Figure 2.3b 

 
Once the links have been made, activate the tool parameters by clicking on the red 
icon that is found in the upper right-hand corner of the "DistanceMarker" tool. Set 
the desired distance between the KPs, which is "1000" in this case (Figure 2.3c). This 
value is inserted in the space following "Segment length in ground units:." Please 
note that the units are metres. Next, click the "OK" button. 
 

 Figure 2.3c 
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2.4. Destination file 

Rename the destination file (in this case "Riv_romaine_p") by clicking on the 
destination data icon (Figure 2.4). 
 

 
Figure 2.4 

2.5. Processing 

To launch the processing in FME Workbench, simply click the "Run translation" 
icon (the green arrowhead). The processing log appears in the "Log" panel (Figure 
2.5), located at the bottom of the window. This panel allows you to follow the 
processing progress and detect any problem that may arise during its execution. 
 

 
 

Figure 2.5 

 

 Page 15/17



 

3. Results 

Once the processing is successfully completed, it is then possible to add the value of 
the kilometre points to the data base of the new file "Riv_romaine_p" and display the 
results on a map (Figure 3.0), using a Geographical Information System (GIS), for 
example. 
 

 
 

Figure 3.0 

 

Conclusion 

To date, this new method allows Hydro-Québec to generate river profiles more quickly in 
locations for which NHN data exists. The SRTM altimetric data were preferred over the 
Canadian Digital Elevation Data (CDED) on GeoBase, despite a 60 m resolution and an 
average altimetric value per pixel, because the SRTM data allow you to obtain a 
homogenous altimetric quality throughout the territory. A river profile crossing several 
map sheets (e.g. CDED) can cause altimetric gaps between sheets or even inconsistencies 
with reality. The Geomatics Unit (Unité Géomatique) at Hydro-Québec Équipement 
compared the altimetric differences between SRTM and LIDAR data. Overall, the 
resulting altimetric difference was comparable to the Canadian Digital Elevation Data 
(CDED) at 1:50,000. However, given what was stated before, the SRTM data meet our 
requirements better. Moreover, this product is presently used to evaluate projects (desk 
studied) on large watercourses. Engineers and managers from the Development of new 
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production facilities Work Unit (Unité Développement de nouveaux aménagements de 
production) recognize the benefits of these new data. This new approach makes it 
possible, among other things, to specify the position of drops in a watercourse and 
calculate the height of the fall in order to determine the potential power of a hydroelectric 
facility. The result is thus a lower margin of errors when estimating the costs and 
possibility of carrying out a project. Further to this success, the Development of new 
production facilities Work Unit asked the Geomatics Unit (Unité Géomatique) to provide 
a product facilitating the identification of transfer tunnels in order to increase the 
hydraulicity of a watershed. 
 
In the future, we can expect that higher completeness levels of NHN data will make it 
possible to obtain all the toponyms of tributary rivers directly in attribute on the Network 
Linear Flow feature elements. Unfortunately, SRTM X-Band data, which have a 30 m 
resolution, are currently available for the United States only. In practice, only a RADAR 
or LIDAR data collection campaign is currently possible to obtain a better resolution 
digital elevation model. 
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